Login or register  
TV
TVRage.Com Forums => Bug Reporting => Apostrophe in episode title renders title attribute of link invalid
psYchotic

Level 1 (57%)
Posts: 4
Since: 30/Oct/07
Message Posted On Wednesday, December 12th 2012 at 11:42 am
In the "My Shows" listing (this could happen elsewhere, though that's really the only feature of tvrage I use), any episode where the title contains an apostrophe (') renders the title attribute of that link's episode number invalid. This has two consequences: the HTML is no longer valid (though both Gecko and Webkit seem to handle it) and when I mouse over this link, the tooltip that appears only shows the part of the episode title up to (but not including) the first apostrophe.

Example: last episode of NCIS (10x09; episode ID: 1065220939). It's title is "Devil's trifecta". The table's row containing this episode looks like so:
Quote:
<tr bgcolor="#FFFFFF" id="brow"><td align="center" width="40" class="b1"><a href="java script: void(0);" onclick="java script: new_rank(4628,0);">00</a></td>
<td class="b1"><a href="/NCIS">NCIS</a></td>
<td class="b1"><a title="Devil" s="" trifecta'="" href="/NCIS/episodes/1065220939">10x09</a> (Dec/11/2012)</td>
<td class="b1"> <a title="You Better Watch Out" href="/NCIS/episodes/1065221461">10x10</a> (Dec/18/2012)</td>
<td align="center" class="b2"><a href="/mytvrage.php?page=myshows&del_id=4628&sort=prev" onclick="return confirm('Are you sure you want to remove this show from the list?');"><img src="/_layout/global/deltvr.gif" border="0" alt="Delete"></a></td></tr>


As you can see, the 'title' attribute of the anchor (<a>) element isn't as it should be. I don't know what's causing this, but I've been running into this bug for ages now, so I thought I'd report it.

Thanks for your time!
TomSouthwell
(Site Moderator)

Level 85 (93%)
Posts: 2193
Points: 120536.7
Mood: determined
Since: 24/Apr/09
Message Posted On Wednesday, December 12th 2012 at 3:29 pm
Hi
I'm sorry to hear you're experiencing some issues. I suspect you may be told to contact the programmes you use to access the My Shows listings, but I will send a message to our programmer in case he has missed this
Blae

Level 49 (32%)
Posts: 1494
Points: 24663.5
Mood: accomplished
Since: 26/Oct/05
Message Posted On Thursday, December 13th 2012 at 9:53 am
Fixed!
psYchotic

Level 1 (57%)
Posts: 4
Since: 30/Oct/07
Message Posted On Saturday, December 15th 2012 at 6:10 pm
That's absolutely wonderful. Thanks for the quick response!
Just a quick question though: is this fixed for future episodes, or should it already work for existing ones? I'm asking because I still see the issue on my list of shows (http://www.tvrage.com/mytvrage.php?page=myshows).
Blae

Level 49 (32%)
Posts: 1494
Points: 24663.5
Mood: accomplished
Since: 26/Oct/05
Message Posted On Sunday, December 16th 2012 at 10:19 am
Hmm, for which episode are you still getting problems?
psYchotic

Level 1 (57%)
Posts: 4
Since: 30/Oct/07
Message Posted On Wednesday, December 19th 2012 at 11:01 am
Sorry for the delay. I just looked through my list of shows, and the first one I can find that still has the problem is Californication 5x12 (http://www.tvrage.com/Californication/episodes/1065109818 ).
Now, the URL I just linked to does not have this problem. It's the "My Shows" page that has the problem. If necessary, I'm willing to give you a list of steps to reproduce the problem. Let me know if you need that!

Channel 4 Unveil All 4 Digital Brand Logo

Channel 4 have today unveiled its new All 4 Brand. The All 4 brand identity brings..

Yasmin Paige chats about upcoming drama series Glue

Yasmin Paige chats about starring on new drama series 'Glue' which begins on..

WATCH: Andrew 'Freddie' Flintoff Opens Up To Piers Morgan, Tonight on itv

The episode of 'Pier's Morgan's Life Stories' airing..